Kullanıcı araçları

Cryptoloop sürücüsü şifrelenmiş dosya sistemini oluşturmak ve bağlamak için güncellenmiş kullanıcı araçlarına ihtiyaç duyar. Güncellenmiş bir util-linux paketi gereklidir ve http://ftp.cwi.nl/aeb/util-linux/util-linux-2.12.tar.gz adresinden bu paket edinilebilir. Yeni bir sürüm her an çıkabilir ve önemli değişiklikler içerebilir, bu yüzden bu NASIL belgesine devam etmeden önce yeni sürümleri ve bu belgenin yeni sürümlerini kontrol etmelisiniz. Şanssızlık eseri util-linux için çok sayıda yama bulunmaktadır. Şifrelenmiş bölümlerin oluşturulma şeklinde ve bunların bağlanmasında değişiklikler söz konusudur. Bir 2.6 çekirdek ile util-linux 2.12 kullanacaksanız en azından şu iki yamayı uygulamalısınız:

util-linux paketini ve yukarıdaki iki yamayı bilgisayarınıza indirin. Önce util-linux paketini aç ın ve iki yamayı uygulayın:

tar xvfz util-linux-2.12.tar.gz

cd util-linux-2.12

patch -p1 </path_to_patchfile/losetup-combined.patch

patch -p1 < /path_to_patchfile/util-linux-2.12-kernel-2.6.patch

Yamaları uyguladıktan sonra util-linux paketini INSTALL dosyasındaki yönergeleri izleyerek derleyin ve kurun.

Ben Gentoo Linux'u tercih ediyorum, gentoo linux util-linux paketini kurarken bu yamaları da otomatik olarak uyguluyor. Diğer dağıtımların da bu yamaların uygulanmış olduğu util-linux'un başka sürümleri olabilir.